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Getting Started with SIwave™: A PCBModel

Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Command font is used for:
l Command line prompts that should be typed exactly as written.
l Script examples.

l Bold type is used for the following:
l Names of windows, workspaces, menu commands, and options.

l Menu commands are often separated by angle brackets. For example, File >Open.
l Labeled keys on the computer keyboard. For example, Enter.

l Italic type is used for the following:
l Emphasis.
l Publication titles.

l The plus sign (+) is used between keyboard keys to indicate that you should press the keys
at the same time. For example, “Press Shift+F1” means to press the Shift key and, while
holding it down, press the F1 key also. You should always depress the modifier key or keys
first (e.g., Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and then press the
last key in the instruction.

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.
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1 - Introduction
This Getting Started Guide is intended to quickly familiarize you with the capabilities of SIwave.
This guide leads you step-by-step through importing a PCB design, setting up and performing
three SIwave analyses, and viewing the results of the simulations.

This guide explains how to perform the following tasks in SIwave:

l Importing a geometric PCB model
l Validating the design
l Running three SIwave simulations:

o Resonant Modes Analysis
o SYZ Analysis
o PSI SYZ Analysis
o AC Current Analysis
o Frequency Sweep of Voltages

l Adding ports, sources, and probes to the PCB as appropriate for each analysis
l Specifying parameter settings for each type of analysis
l Creating 2D plots of the results, and comparing the results from the three solutions

The PCB Model
The PCBmodel used in this Getting Started Guide consists of an 8-layer PCB. Layers 2 and 7
are planes for power and ground.

Getting Started with SIwave™: A PCBModel
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Getting Started with SIwave™: A PCBModel

Expected Results
The analyses will demonstrate how frequency-dependent impedance and voltage differences
between the power and ground planes can cause signal integrity issues such as voltage ripple.
The resonant modes identified in the Resonant Modes Analysis can be clearly seen in the
impedance plots from the SYZ Analysis and the graphs of voltage swings from the Frequency
Sweep.
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2 - Setting Up the Design
This section explains how to perform the following tasks:

l Importing and saving a project
l Setting the visibility of geometric and circuit elements
l Viewing the Layers workspace and layer stackup
l Identifying power/ground nets
l Running a validation check on the design

Importing and Saving the Project
To begin, import the PCB design and its components from an Ansys Neutral File (*.anf). This file
contains information about the PCB's geometry, layer stackup, padstacks, vias, materials, and
discrete components.

1. Launch SIwave.
2. If theWelcome to SIwave window opens at launch, close it.
3. Click the Import tab.
4. In the Ansys EDA Layouts area, click ANF.

The Select Ansoft Neutral File to Import window appears.

5. Depending on your operating system, navigate to one of the following locations:
l Windows: \Program Files\ANSYS Inc\v252\AnsysEM\Win64\Examples\SIwave
l Linux: /Program Files/ANSYS Inc/v252/AnsysEM/Linx64/Examples/SIwave

6. Select the file siwave_board.anf.
7. ClickOpen.

The Select nets to import from siwave_board window appears.

Getting Started with SIwave™: A PCBModel
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Getting Started with SIwave™: A PCBModel

8. Leave the settings as-is, and click Import Configuration.

If a Component Import Overwrite message appears, click Yes to All to overwrite any
existing names.

If the SIwave Workflow Wizard opens, close it to reveal the Modeling workspace.

The design should look like this:
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Note:

You can change SIwave's background colors from the View tab:

9. Click File > Save As.

The Save As window appears.

10. Browse to a directory where you have write permission. Enter a name for this project, such
as siwave_board_test1.siw.

11. Click Save.

Setting PCB Element Visibility
PCB element visibility is controlled from the Layers workspace and the View tab.

To turn on visibility for geometric elements (planes, traces, pads, vias, and circuit elements):

Setting Up the Design 2-3
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Getting Started with SIwave™: A PCBModel

1. Navigate to the Layers workspace.
2. Use the Show All check boxes ( ) to enable visibility for all parts on every layer.

When you are finished, the Layers workspace should look like the following:

TheModeling workspace should look like the following:
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Getting Started with SIwave™: A PCBModel

Note:

While no further changes are necessary for this Getting Started Guide, additional
visibility options are described in SIwave's online help.

Viewing the Layers Workspace and Layer Stackup
The Layers workspace and the Layer Stackup Editor control the visibility and properties of the
package layers.

Layers can be viewed in either outline or filled mode.

To set the layers for this project to filled mode:

1. Navigate to the Layers workspace.
2. Click within the colored rectangles to change layers from outline to solid fill:

l Set Surface, L7, and BASE to solid fill.
l Leave the remaining layers as outlines.

The Layers workspace should look like the following:
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The Modeling workspace should look like the following:

Viewing the Layer Stackup
To view the layer stack:

1. Navigate to the Home tab.
2. In the Edit Tools area, click Layer Stackup Editor.

The Layer Stackup Editor appears.

Setting Up the Design 2-6
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Getting Started with SIwave™: A PCBModel

3. Here, you can change the properties for one or more layers. For now, you need only be
aware that this window exists. Later, this guide will focus on the interactions between layers
L2 and L7.

Identifying Power and Ground Nets
In this section, you will explore the Nets workspace.

Note:

By default, the Nets workspace is located on the upper-left side of the SIwave window.
Workspaces can be moved by dragging and dropping them to another location.

Before performing any simulations, power and ground nets in the design must be identified.

Nets containing large planes must be classified as Power/Ground nets. Signal nets containing
microstrip and stripline routing need to be classified as Non Power/Ground nets. This enables
the solver to judiciously choose the mesh refinement and optimization strategies for the signal
and power/ground nets.

To identify power/ground nets:

1. In the Nets workspace, which defaults to Single Ended Nets, select the Power/Ground
Identification tab.

Setting Up the Design 2-7
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Getting Started with SIwave™: A PCBModel

2. Click Auto Identify to have SIwave automatically classify the power and ground nets.

NetsGND, P28VA, and VCC should be classified as Power/Ground Nets.

3. If any net is incorrectly identified, click to highlight the net name and use the up and down
arrows to move it to the correct list.
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Getting Started with SIwave™: A PCBModel

Running a Validation Check
Run a validation check of the PCB design before running any simulations. This check identifies
several common layout and design errors.

1. Click Tools. In the Inspection Tools area, click Validation Check.

The Launch Validation Check window appears.

2. Leave the default settings, and clickOK to start the check.

TheMessages window updates with a Process Monitor showing the status of the
validation check.
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Getting Started with SIwave™: A PCBModel

When the process is finished, the Validation Check Results window appears.

If there were errors or warnings that SIwave could resolve, the Auto Fix check boxes would
be available.

The design is ready for simulation when no errors are found.

3. ClickOK to close the window.
4. Click FILE > Save to save the updated PCB design.
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3 - Resonant Modes Analysis
This section explains how to perform the following tasks:

l Running a Resonant Modes analysis
l Viewing the results as a data table or as 2D plots

Running the Resonant Modes Analysis
Traces routed through power and ground planes can exhibit signal integrity problems. The
resonant mode calculation is the first step in identifying non-ideal plane behavior that can affect
signal integrity.

Set up an SIwave Resonant Modes analysis:

1. Click Simulation > Compute Resonant Modes.

The Compute Resonant Modes window appears.

2. Verify thatMinimum Frequency is set to 2.55238E+08. If it is not, click Restore
Recommended Minimum Frequency.

3. Set theMaximum Frequency to 2e9 (2 GHz).
4. Set the # of Modes to compute to 10.

Getting Started with SIwave™: A PCBModel
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Getting Started with SIwave™: A PCBModel

5. Click Launch to begin the analysis.

TheMessages workspace updates with a progress bar.

When the analysis has finished, it appears in the Results workspace:

Viewing Resonant Modes Analysis Results
After the analysis has finished, Resonant Modes results can be viewed in a table, or as two-
dimensional plots overlaid on the PCB design.

To view tabular results:

1. In the Results workspace, double-click Resonant Mode Sim 1 (or whatever you've named
the simulation).
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The Resonant Modes window appears.

At the center of this window, two drop-down menus allow you to compute the voltage differences
between two planes.

Perform the following steps to plot the voltage differences between layers L2 and L7, the power
and ground planes:

1. Use the drop-down menus under Plot voltage difference between planes on to select L2
and L7 respectively.

2. Click Compute to generate the 2D plot data from the solution data.

The lower part of the window updates to display the modes available for plotting. There are
ten modes, and the underlying Modeling workspace updates to display Mode 1.

Resonant Modes Analysis 3-3

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with SIwave™: A PCBModel

You'll notice that layer L7's display mode obscures part of the plot.

3. From the Layers workspace, click the solid color block next to L7 to revert it to outline mode.

Resonant Modes Analysis 3-4
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The entire plot is now visible:

4. Click on each row in turn to see the voltage difference as a color map on the PCB. As
indicated on the left, areas with large positive voltages appear as red, while areas with large
negative voltages appear as blue.

Resonant Modes Analysis 3-5

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with SIwave™: A PCBModel

5. To view the modes in sequential animation, click Phase Animation.

The Phase Animation window appears.

6. Leave the Start, End Angle, and Step Size settings as their defaults, and clickGenerate
Frames.
The Frames area updates with a list.

Resonant Modes Analysis 3-6
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7. Click through the frames one by one to change the underlying Modeling workspace to that
frame, or use the Play and Pause buttons to control an animation of the frames.

8. Click Close to terminate the animation.
9. Click Close again to close the Results window.
10. Click File > Save to save the design with your Resonant Modes analysis results.
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4 - SIwave SYZ Analysis
This section explains how to perform the following tasks:

l Defining pin groups
l Defining a port between the pin groups
l Generating the SYZ-parameters for selected power supply nets
l Viewing the frequency-dependent impedance of the planes on an X-Y plot

Defining Pin Groups for GND and VCC 
To launch the Pin Group Manager:

1. Click Tools > Create/Manage Pin Groups.

The Create/Manage Pin Groups window appears.

Getting Started with SIwave™: A PCBModel
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Define a pin group for theGND net:

1. From the Part Namemenu, selectMACH230_SMSOCKETAMD.
2. From the Reference Designator list, select U41.
3. In the Nets list, ensure that theGND box is checked, and that no other nets are selected.
4. Click Create Pin Group(s).

The Pin Group appears in the Pin Group List.

Define a pin group for the VCC net:

1. In the Nets list, uncheck theGND box and check the VCC box. Ensure that no other check
boxes are selected.

2. Click Create Pin Group(s).

Both the GND and VCC pin groups should now appear in the Pin Group List.

3. Click Close.

SIwave SYZ Analysis 4-2
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Defining a Port Between Pin Groups
Define a port on component U41.

1. Click Tools >Generate Circuit Element on Components.

The Circuit Element Generation Dialog appears.

2. In the Positive Terminal Component section, use the Part Name drop-down menu to
selectMACH230_SMSOCKETAMD and the Ref Des drop-down menu to select U41.

3. In the Reference Terminal Component section, enable the Same as Positive Terminal
check box, which will populate the Reference Terminal Component fields with the same
information.

4. In the Circuit Element Positive Terminal section, expand the Pin Groups list and select
the U41_VCC_Group pin group.

5. In the Circuit Element Reference Terminal section, expand the Pin Groups list and
select the U41_GND_Group pin group.

6. In the Circuit Element Type section, select the Port radio button.

Your selections should look like the following:
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7. Click Create.

The Port Properties window appears.
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8. Shorten the name to U41_VCC.
9. Set the Reference Impedance to 1Ohm.
10. ClickOK to accept the port definition.
11. ClickOK to exit the Circuit Element Generation window.

Generating SYZ Parameters
Next, we calculate the frequency-dependent impedance response at port U41_VCC.

The active components on the PCB draw current through the power supply nets, such as VCC. If
the impedance of the VCC net is too large, ripple voltage may be induced between VCC and
GND when the components switch. The frequencies previously identified by the Resonant
Modes Analysis correspond to peaks in the impedance of the power supply VCC net.

1. Select the Simulation tab. In the SIwave area, click Compute SYZ Parameters.

Note:

Ensure you are in the correct area of the Simulation tab, as there is another
Compute SYZ Parameters link for PSI.

The Compute SYZ-parameters window appears, populated with default settings.

SIwave SYZ Analysis 4-5
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2. In the Frequency Range Setup section, set the Start Freq to 0 Mhz.
3. Set the Stop Freq to 1 GHz. Note that theMin Rise/Fall Time value changes to fit the

maximum frequency (in this case, 5e-10).
4. Set the Num. Points to 200.
5. Leave the Distribution as Linear.
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6. In the Sweep Selection section area, ensure that Discrete Sweep is selected.
7. Leave any other settings as-is.

Your settings should look like the following:

8. Click Launch to launch the SYZ analysis.
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TheMessages workspace updates with a progress bar showing simulation progress. When it
has finished, you can view the impedance response.

Viewing Impedance Response
To view the frequency-dependent impedance response:

1. Select the Results tab. In the SIwave area, click the SYZ icon to access its drop-down
menu. Select SYZ Sweep 1 > Plot Magnitude....

The S-parameter Plot window opens.

2. Click the Z-parameter Plot tab at the bottom of the window.

The window changes to Z-parameter Plot.

SIwave SYZ Analysis 4-8
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Your port should automatically be selected for plotting. If it is not, enable the check box in
the Plot column.

Note:

This design only has one port defined, but it is possible to display multiple plots at
once.

Note:

You can change many aspects of the plot, including labels, scaling, and color.
Double-click anywhere within the plot window to launch the Properties window.

3. Close the report.
4. Click FILE > Save to save the project with the impedance result.
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5 - PSI SYZ Analysis
This section explains how to perform the following tasks:

l Generating SYZ parameters for selected power supply nets using the PSI solver
l Viewing the frequency-dependent impedance of the planes on an X-Y plot

Prerequisite: Defining Pin Groups and Ports

The PSI solver uses the same pin groups and port settings as the SIwave SYZ analysis.

If you have not yet completed the previous chapter (SIwave SYZ Analysis), please do so to set
up your pin groups and ports.

Generating SYZ Parameters using PSI
Next, calculate the frequency-dependent impedance response at port U41_VCC using the 3D
full-wave PSI solver.

1. Select the Simulation tab. In the PSI area, clickOptions.

Note:

Ensure that you click the PSI Options icon, as there are others.

The PSI Options window appears.

Getting Started with SIwave™: A PCBModel
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2. Ensure that Local Analysis is selected. In the box below, use the up and down arrows to
change the number of cores to use. To use all cores, click the up arrow until you reach the
maximum.

Important:

For best performance, Ansys generally recommends at least 8, and optimally 12-
16 cores.

3. Leave all other options as-is, and clickOK to exit the PSI Options window.
4. Navigate to the Simulation tab. In the PSI section, click Compute SYZ Parameters.

The Compute SYZ-parameters using PSI window opens.
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5. Ensure the Start Freq is set to 10MHz.
6. Set the Stop Freq to 1GHz.
7. Under Sweep Options, select Interpolating Sweep (AFS), and select Fast Sweep and

Adaptive Sampling. The Fast Sweep algorithm improves run time by requiring fewer
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samples to simulate, but uses more memory. Fast Sweep may not be used if insufficient
memory is available.

Your settings should look like the following:

8. Click Launch to begin the PSI SYZ analysis.
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TheMessages workspace updates with a progress bar. When the simulation has finished,
you can view the impedance response.

Viewing Impedance Response
To view the frequency-dependent impedance response:

1. From the Results workspace, double-click PSI S-parameter Sweep.

Note:

If you have hidden your Results window, navigate to the results using the Results
tab. In the PSI area, click SYZ > PSI S-Parameter Sweep > Plot Magnitude.

The Y-parameter Plot window opens.

2. Click the Z-parameter Plot tab to view the plot.
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3. Click FILE > Save to save the project with the PSI SYZ results.
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6 - PSI AC Current Analysis
This section explains how to perform the following tasks:

l Creating a Voltage Source
l Calculating AC currents on selected power supply nets
l Viewing current distributions as 2D plots
l Exporting total radiated power

Creating a Voltage Source
AC Current analysis requires the existence of one or more sources as excitations.

Because the analysis result is a current, the effect of the changing plane impedance will be most
clear if a constant voltage excitation is used.

To create a voltage source:

1. Click Tools >Generate Circuit Element on Components.

The Circuit Element Generation window appears.

2. In the Positive Terminal Component section, use the Part Name drop-down menu to
selectMACH230_SMSOCKETAMD and the Ref Des drop-down menu to select U41.

3. In the Reference Terminal Component section, check the Same as Positive Terminal
check box to select the same.

4. In the Circuit Element Positive Terminal section, expand the Pin Groups option and
select U41_VCC_Group.

5. In the Circuit Element Reference Terminal section, expand the Pin Groups option and
select U41_GND_Group.

6. In the Circuit Element Type section, select Voltage Source.

Your settings should look like the following:
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7. Click Create.

The Set Voltage Source Properties window appears.
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8. Shorten the name to U41_VCC_VSRC.
9. Ensure that Frequency Independent is selected.
10. Ensure theMagnitude is set to 1 Volt, the Parasitic Resistance is set to 1E-06 Ohms, and

the Phase is set to 0 Degrees.
11. ClickOK to accept the Voltage Source definition.
12. ClickOK to exit the Circuit Element Generation window.

Calculating AC Currents
The AC Currents simulation calculates surface current, and can reveal regions of high
impedance that may occur due to antipads, cutouts, or discontinuities in ground planes.

To calculate the surface current flowing on the VCC and GND planes:

1. Select the Simulation tab. In the PSI area, click Compute AC Currents. to open the
Compute AC currents using PSI window.
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2. In the Excitations area, ensure that Use sources defined in project is selected.
3. Set the Start Freq to 500 MHz.
4. Set the Stop Freq to 1 GHz.
5. Set the Num. Points/Step Size to 50. Please note that for each frequency point, a number

of data files are written to the disk. The available disk space must be considered before
specifying too many frequency points for simulation.

6. Set the Distribution to Linear.

Your settings should look like the following:
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7. Click Launch to begin the PSI AC current analysis.

TheMessages workspace updates to display a progress bar. When the analysis has
completed, you can view AC currents as 2D plots.

Viewing AC Currents as 2D Plots
To view the results plot:

1. Select the Results tab. In the PSI area, click AC Currents > PSI AC Sweep > Plot
Currents.

TheModeling workspace updates to show the plot, and the PSI AC Current Simulation
Results window appears:

2. In the Layer Toggle column ( ), clear the check boxes for every layer except L2.
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3. In the Frequency list, click each frequency to view AC currents at that frequency.
4. Options in the Animation area allow you to view an animation of the plot at all frequencies,

using the Play and Pause buttons.

Exporting Total Radiated Power
After running the AC current analysis, the total power radiated from the PCB can be exported to
a *.csv file.

1. Click the Results tab. In the PSI section, click AC Currents > PSI AC Sweep > Export
total radiated power.

2. Name and save the .csv file to any location.
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3. View the saved file in any text editor.
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4. In SIwave, click FILE > Save to save the project with the AC Current analysis result.
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7 - Frequency Sweep of Voltages
This section explains how to perform the following tasks:

l Disabling Voltage Sources
l Creating a Current Source on a component
l Placing a Voltage Probe in a region of interest
l Calculating a Frequency Sweep of Voltages
l Viewing a Voltage Probe plot

Disabling Voltage Sources
The voltage source used in the AC Current analysis should be disabled, so that it does not
interfere with the voltage frequency sweep.

1. In the Components workspace, ensure that Voltage Sources is selected.
2. Right-click on Voltage Sources and select Set All Voltage Sources Not Active.

The green check mark adjacent to Voltage Sources becomes a red X.
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Creating a Current Source on a Component
The Frequency Sweep analysis requires one or more sources as excitations.

To define a Current Source:

1. Click Tools >Generate Circuit Element on Components.

The Circuit Element Generation window appears.

2. In the Positive Terminal Component section, use the Part Name drop-down menu to
selectMACH230_SMSOCKETAMD and the Ref Des drop-down menu to select U41.

3. In the Reference Terminal Component section, select Same as Positive Terminal.
4. In the Circuit Element Positive Terminal section, expand Pin Groups and select U41_

VCC_Group.
5. In the Circuit Element Reference Terminal section, expand Pin Groups and select U41_

GND_Group.
6. For the Circuit Element Type, select Current Source.

Your settings should look like the following:
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7. Click Create.

The Set Current Source Properties window appears.
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8. Shorten the name to U41_VCC_ISRC.
9. Set the Frequency Independent Magnitude to 1E-5 Amps.
10. Ensure that the Parasitic Resistance is set to 5E+07Ohms.
11. Ensure that the Phase is set to 0 Degrees.
12. ClickOK to accept the current source definition.
13. ClickOK to close the Circuit Element Generation window.

Creating a Voltage Probe
The problem of induced ripple voltage in the Power Distribution Network (PDN) can be
investigated by measuring the voltage between the VCC and GND nets, using a voltage probe
placed at a location of interest on the PCB.

You will place a probe at the lower-right corner of the PCB, where U41 is located. The X- and Y-
coordinates for the probe are X=8500mil, Y=0mil.

Perform the following steps:

1. Make sure the Units field in the menu bar is set to mils.

Frequency Sweep of Voltages 7-4

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with SIwave™: A PCBModel

2. Select the View tab. Use the Zoom In icon (or your mouse wheel) to enlarge the lower-right
corner of the PCB.

3. Select the Home tab.
4. In the Circuit Elements area, select the Add Voltage Probe icon ( ).

The cursor changes to a small bullseye.

5. Use the location indicators at the bottom-right of the screen to position your cursor at x: 8500
mils, y: 0 mils.

6. Click the left mouse button twice, slowly each time. The first click locates the positive
terminal, the second click is for the reference terminal. The terminals are located in the
same position since these probes measure the voltage between two planes.

The Select layers for voltage probe terminals window appears.

7. For the Positive Terminal Resides on Layer, select L7 (VCC).
8. For the Negative Terminal Resides on Layer, select L2 (GND).
9. ClickOK to close the Select layers for voltage probe terminals window.

The Edit Probe Name window appears.
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10. Enter VPROBE1, and clickOK.

The voltage probe (a yellow circle in the following figure) appears.

Running a Frequency Sweep
Frequency sweep calculates the voltages across the VCC and GND planes at the locations of
the probe. The SIwave frequency sweep shows how the current drawn by a device can lead to
voltage ripple in the power distribution system.

Run the frequency sweep analysis:

1. Click Simulation > Compute Frequency Sweeps...

The Compute Frequency Sweep window appears.

2. For excitations, select Use sources defined in project.
3. Set the Start Freq to 500MHz.
4. Set the Stop Freq to 1GHz.
5. Set the Num. Points to 200.
6. Set the Distribution to Linear.
7. Set the Voltage Surface Plot Options to plot voltage difference between layers L2 and

L7.
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Your settings should look like the following:

8. Click Launch to begin the simulation.

TheMessages workspace displays a progress bar that lets you know when the simulation is
complete.

Plotting Probe Voltage
To plot the voltages at the probe locations:
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1. Select the Results tab.
2. Click Frequency Sweep > Frequency Sweep 1 Results > Plot Probe Voltages.

The Voltage Probe Plot Generation window appears.

3. Ensure that Plot magnitude and VPROBE1 are selected.
4. Click Create Plot.

Ansys Electronics Desktop launches. The Reporter window opens, displaying the plot of
magnitude versus frequency.
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The peaks in the voltage correspond to resonant mode 4, mode 8, and mode 10.
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